Menu
  • Accueil
  • Forum
  • WiFaq
  • Contribuer
  • Recherche
  • Polos WlanFr
  • Wlanfr
        ø Charte
        ø Mentions légales
  • Liens
        ø Backend WlanFr
        ø Wireless
        ø Constructeurs
  • Syndication RSS
  • Essais Matos
  • Nos tests...
    Cartes PCMCIA
  • Les tests PCMCIA
  • Netgear MA401
  • NoName PCMCIA
  • SEAT810
  • SEAT830
  • SEAT910
  • USR 805410
    Cartes PCI
  • D-Link DWL520+
  • Netgear MA311
  • SEAT710
  • USR 805416
    Cartes USB
  • Les tests USB
  • Netgear MA111
  • SEAT 510
    Access Point
  • Les Tests AP
  • Aironet 1100
  • BeWan 6104W
  • D-Link
        ø DSL-604+
        ø 900AP+
  • Draytek
        ø Vigor 2200VG
        ø Vigor 2600We
  • HostNet NoName
  • LinkSys WAP11
  • Matériel Linksys
  • LXB5410
  • NetGear
        ø DG824M
        ø PCI MA311
  • Seat 1010
  • Seat 2030 (M ou P)
  • TRENDnet
        ø TEW-310APB
        ø TEW-311BRP
  • USR 805450
    Antennes
  • HomeMade
        ø La Caro
        ø Une omni simple
  • SEAT205
  • SEAT318
    Modems ADSL
  • Seat 100
    Tests globaux
  • Forum
  • Général
  •     ø Bla Bla
        ø ART
        ø Sécurité
        ø Logiciels
        ø Suggestions
        ø Jeux/Loterie
  • Matos sans fil
  •     ø Carte PCMCIA
        ø Carte PCI
        ø Access Point
        ø Câble Connecteur
        ø Antennes
        ø Tout en un
        ø Carte USB
        ø P'tit coup d'pouce
        ø PC portable/ PDA
        ø Autre matériel
        ø Carte C. Flash
  • Vente Groupée
  •     ø Netgear Wireless
        ø Vigor Wireless
        ø Général
  • Troc ou vente PAP
  •     ø Troc
        ø Vente
  • Forum dédié à
  •     ø Inventel
        ø Draytek Gamme VIGOR
  • VoIP & VoWi-Fi
  •     ø Les logiciels
        ø Matos VoIP & VoWi-FI
        ø Asterisk
  • Console de jeux wireless
  •     ø Nokia N-Gage
  • Jeux Vidéos
  • Dossier
  • Les DB, DBm, DBi
  • Wifi et sécurité
  • Sécuriser son AP avec Linux
  • Comment flasher les chipsets Intersil Prism
  • Comment récupérer un flash raté
  • Arduino et Radio
  • Arduino et Radio avec les NRF24L01+
  • Conf Linux
  • Netgear MA311
  • Debian et la MA311
  • D-Link DWL 650+
  • Chipset Atmel et Linux
  • Installation WPC54G
  • Netgear WG311v2 sous Debian
  • Netgear WG311v2 ACX100
  • Netgear WG511
  • Belkin USB Wireless G
  • Menu utilisateur
    Vous êtes connecté en Invité
    Pseudo
    Mot de passe
    Ne pas m'oublier
  • Enregistrez-vous
  • Mot de passe oublié

    Ils sont là


    Il y a aussi 6 invité(s).


    Visites
    Stats du jour596 Pages
  • L E  F O R U M

    Racine » Matos sans fil » PC portable/ PDAPage : 1 ( 1 )Répondre  Nouveau Message
    Auteur Sujets : portable xbook & mandriva 2006 & wifi


    Le : Mercredi 30 Août 2006 à 15:05
    Novice


    Messages : 8
    Inscrit: 30-12-2005 16:24
    Bonjour tout le monde (et surtout navy le champion )

    J'essaye de faire fonctionner mon xbook tout bo sous mandriva 2006 (version official, tout à jour, y compris noyau)

    Je précise que ca fonctionne sous windose.

    Donc, j'ai investigué et j'ai trouvé :
    - drakroam semble fonctionner et trouver le réseau. J'ai bien mis WPA et le bon SSID que j'ai indiqué sur mon routeur (un netgear)
    - quand je fais "connecter" il ne se passe pas grand chose, et le syslog me dit
    "kill switch must be turned off for wireless networking to work"

    donc j'ai cherché un chti peu et j'ai trouvé rfswitch, que j'ai compilé et installé. J'ai aussi trouvé :
    http://rfswitch.sourceforge.net/?page=laptop_matrix
    qui me suggère, pour le xbook de mettre :

    modprobe acerhk usedritek=1 autowlan=1 force_series=290
    echo 1 > /proc/driver/acerhk/wirelessled

    ce que j'ai fait, mais dmesg me dit :
    "
    could not find request handler, possibly not all functions available
    Coule not find model string, will assume type 200 series
    can't find bios routine, cannot do anything for you, sorry!
    Acer Travelmate hotkey driver v0.5.18
    Your hardware does not need polling enabled for hotkeys to work
    enabling wlan hardware
    "

    mais le bouton wifi continue de clignotter seulement (il est fixe sous windows qd la cnx est établie, et je n'ai pas d'ip :
    iwconfig :
    eth2 unassociated ESSID:off/any Nickname:"portable"
    Mode:Managed Channel=0 Access Point : 00:00:00:00:00:00:00
    Bit Rate : 0kb/s Tx-Power=20dBm
    Retry limit : 7 RTS thr:off Fragment thf:off
    Encryption key:off
    Power Management:off
    Link quality:0 signal level:0 Noise level:0
    (les 2 lignes suivantes tout à 0 aussi)

    voili voilou, un bisou à celui qui m'aidera

    Petite précision qui peut être utile : mon ipw2200 et il est indiqué : PRO/Wireless 2915ABG MiniPCI Adapter dans le centre de ctrl mandriva.


    Liens sponsorisés sur ce sujet :
    []


    Le : Mercredi 30 Août 2006 à 16:40
    Modérateur


    Messages : 4947
    Inscrit: 12-10-2003 20:58
    suite de l'autre post donc

    essayes de tester deja sans cryptage
    si tu fais
    ifconfig eth2 up
    iwconfig eth2 mode Managed
    iwconfig eth2 essid ton_essid
    iwconfig
    dhclient eth2
    ---

    Linux @ Cergynux.Net
    Répondre ]


    Le : Mercredi 30 Août 2006 à 20:05
    Novice


    Messages : 8
    Inscrit: 30-12-2005 16:24
    Trop d'enfer, ca marche !!!

    Mais bon, je diffuse l'adresse du réseau à tout vent et j'ai désactivé l'authentification WPA, ca ne marche pas sinon.

    J'ai juste mis un controle sur l'adresse MAC, histoire d'éviter les surprises (j'habite Marseille, et même si je mon bureau est isolé au milieu d'un parc, c'est une ville, le voisin le + proche est à 50m)

    donc maintenant, comment puis-je faire pour faire fonctionner l'authentification WPA mon bon Navy ?
    Répondre ]


    Le : Jeudi 31 Août 2006 à 02:16
    Modérateur


    Messages : 4947
    Inscrit: 12-10-2003 20:58
    Bon, allons y avec le wpa alors

    pour le disable du ssid, ca doit marcher aussi
    masque le, et refaits les memes manip, ca devrait fonctionner aussi

    pour le wpa, installes le paquet wpa_supplicant et on voit apres
    ---

    Linux @ Cergynux.Net
    Répondre ]


    Le : Jeudi 31 Août 2006 à 12:30
    Novice


    Messages : 8
    Inscrit: 30-12-2005 16:24
    wpa_supplicant était déjà installé.

    J'ai re-re-re-vérifié que le mdp wpa était le même coté routeur et mandriva, et malgré tout, ca ne passe pas...
    iwlist eth2 scan donne :
    ESSID:"KOHA-PP" comme prévu
    protocol : 802.11g
    Mode: Master
    Encryption key : on
    Bit rate : 54Mb
    Extra : rates (...)
    Quality : 100/100
    Extra : wpa_ie=dd...
    Extra: Last beacon 9ms ago


    Répondre ]


    Le : Jeudi 31 Août 2006 à 14:12
    Modérateur


    Messages : 4947
    Inscrit: 12-10-2003 20:58
    as tu deja testé sans cryptage mais avec le nom reseau masqué ?

    pour wpa_supplicant, modifie le fichier de conf /etc/wpasupplicant.conf comme suit

    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    eapol_version=1
    ap_scan=2
    fast_reauth=1

    network={
    ssid="Mon SSID"
    scan_ssid=1
    psk="Mot de passe WPA"
    key_mgmt=WPA-PSK
    proto=WPA
    pairwise=TKIP
    group=TKIP
    }

    ---

    Linux @ Cergynux.Net
    Répondre ]


    Le : Jeudi 31 Août 2006 à 14:26
    Novice


    Messages : 8
    Inscrit: 30-12-2005 16:24
    J'avais déjà une bonne partie de tout ca, j'ai juste du :
    - changer ap_scan=1 => ap_scan=2
    - ajouter key_mgmt,proto,pairwise et group

    Ca ne change rien, ca marche tjs pas.
    Dans le syslog :
    ifplugd 0,28 initializing
    using interface eth2/00:12:F0... with driver <ipw2200> (version 1.0.6)
    using detection mode SIOCETHTOOL
    Initialization copmplet, link beat not detected.

    Pour le test sans cryptage, mais nom de réseau masqué, ca ne marche pas non plus.

    Répondre ]


    Le : Vendredi 1er Septembre 2006 à 12:59
    Modérateur


    Messages : 4947
    Inscrit: 12-10-2003 20:58
    le test wpa, c'est avec le nom reseau masqué ?
    ---

    Linux @ Cergynux.Net
    Répondre ]


    Le : Mardi 05 Septembre 2006 à 10:11
    Novice


    Messages : 8
    Inscrit: 30-12-2005 16:24
    bon, ca y est, c'est réglé !

    en fait, il y a un bug sur mandriva 2006 très probablement : lorsque l'on MODIFIE un paramètre wifi, ca marche po.
    Lorsqu'on SUPPRIME la connexion wifi, et qu'on la RECREE, ca fonctionne farpaitement.

    donc j'ai un portable avec wifi WPA qui marche très bien.

    J'ai laissé la déclaration du SSID publique, le WPA étant sécurisé (+ controle de la MAC address, même si je sais que c'est contournable par un mec un tout petit peu compétent)
    Répondre ]


    Le : Mardi 05 Septembre 2006 à 11:29
    Modérateur


    Messages : 4947
    Inscrit: 12-10-2003 20:58
    J'avais remarqué que parfois qd on modifie, au lieu de remplacer les parametres ds le fichier de conf ifcfg-wlan0, cela reecrit de nouvelles lignes avec les nouveaux parametres
    y'a aussi parfois un pb avec l'adresse mac, qui est incsrite ds /etc/ifrename ou /etc/iftab avec la mauvaise interface


    ---

    Linux @ Cergynux.Net
    Répondre ]
    Racine » Matos sans fil » PC portable/ PDAPage : 1 ( 1 )Répondre  Nouveau Message
    BBPortalS V.1.5.11 (c) BBsProcesS Coded by Patrice